OPIF (Open UI Java Script Incompatibility Finder) ist ein brandneues Tool. Es erkennt kritische Java Script Codeteile, die bei einem Upgrade auf Siebel Open UI zu Hindernissen führen können.

Eines dieser Hindernisse kann die Verwendung von inkompatiblem Browser Script Code sein. Während wir bei Server Script keine wesentlichen Themen identifiziert haben, können inkompatible Code-Strukturen im Browser Script (Java Script) zu Problemen beim Upgrade führen.

Aus diesem Grund haben wir ein Werkzeug entwickelt, welches auf dem Markt einmalig wie hilfreich und zeitsparend ist. Dieses Tool erkennt kritischen Java Script Code und gibt sowohl die Codestelle inklusive der Code-Zeile aus, als auch Hinweise zur Lösung.

Hier ein Beispiel:

ec4u-Siebel-OpenUI-Inkompatibilität-Browser-Script-Finder-und-Verbesserer-Report-300x39

Tool Report

(Wir haben sowohl die Objektnamen als auch die überprüften Methoden aus datenschutzrechtlichen Gründen verändert)

Diese Überprüfung führen wir seit einigen Wochen als Teil unseres Angebots „Siebel Open UI Assessment“ durch. Die Ergebnisse werden im Rahmen des Einsatzes besprochen. Danach sind unsere Kunden in der Lage, die Änderungen durchzuführen oder bekommen die Schätzungen übermittelt bei einer Beauftragung von externen Kräften.

Diese Herangehensweise spart eine Menge Zeit und vermeidet eine komplizierte Fehlersuche. Eine Beseitigung der Inkompatibilitäten vor dem eigentlichen Upgrade kann eine Alternative sein wie auch eine Korrektur im Rahmen eines Upgrades auf Siebel Open UI.

Unsere Siebel Open UI Experten beraten Sie gerne und wir freuen uns auf Ihre Kontaktaufnahme via marketing@ec4u.com.